Project EXI

The building of a Marlin 5EXi kit car, using a Seat Leon 1.8T 20v Donor

May 25 2011

Dashboard is flocked

300-Dashboard/IMG_6048_w160_h120_cw160_ch120_thumb_c-stsa.co.uk.jpg

Just heard my dashboard is ready to be collected.
Should look good flocked, off to collect it tonight at 8pm


Update: Collected the dashboard, and all I can say is "Wow" that looks cool.


Posted by Steve | Permanent link | File under: interior

May 18 2011

Engine Fixed !!!!

In Previous posts my engine was running really rich and was running like a diesel.
Today I think I finaly manged to fix it, I was able to get hold of a second hand MAF for £30. immediatly after installing, the engine idled without black soot/smoke coming out of the exhaust. I left the engine running, it still sounded rough but settled down and purred at idle, think the early roughness was down to the ECU readapting to a correct input from the MAF, and cleaning out of carbon deposits when it ran rich.

Once the coolant was upto 75C I gave it some revs, it did cough once halfway up at 4000 rpm, again readaption by the ECU, but continued to 6500rpm with no signifcant problems, letting off the throttle the revs dropped down, no bangs no pops and idled at 800rpm.
So having fitted new spark plugs, new coils (one was faulty), new lambda sensor (this was faulty) and a new MAF. Then engine runs as expected.

I bough a VCDS Lite licence which has also arrived, so now I will perfrom a throttle body adapation, and checks on other components like lambda values, throttle position sensors, and make sure everything is right.
Will also record some sensor values and use this as a baseline if a problem shows itself up in the future.

I have to say, the engine never ran as well as it did today, so I think the MAF, lambda and coilpacks were experincing problems from the beginning.

Need to redo some of the ECU wiring, I had to take it apart in this process and I will fit another relay to provide power to these sesnor instead of taking the 12V from my fuel pump circuits. I will leave the injectors on the fuel pump supply as they are so closely tied together, it makes no sense to split them.
If one sensor fails it wont take out my fuel pumps.


Posted by Steve | Permanent link | File under: powertrain

May 15 2011

Running Rich

Now I have my diagnostics working, it feels about the right time to look at the engine problems some more.
More specifically the really rich fuel mix, and the sooty smoke.
Diagnostics were showing a fault in the heater of lambda sensor #1. The thing here is my car used to have 2 lambda sensors, so is it complaining about the one that missing. Jim at SJB confirmed that in VAG com there are reffered to as sensor #1 and sensor #2
A few websites (Good guide on lambdapower.co.uk) show that a lambda sensor should produce between 200mV (When lean) and 900mv (When rich) my lambda sensor was showing 50mv!! Wow that is telling the ECU that it is super lean, so the ECU will fuel some more, explains the rich fuel!!
With my engine running, my sensor showed 200mv.
I was able to borrow a sensor, when in the exhaust flow this read 900mv, so I am suspecting that my lambda sensor needs replacing.
Ive ordered one and should have it tomorrow, so fingers crossed that fixes it.


Posted by Steve | Permanent link | File under: powertrain

May 12 2011

Diagnostic port connections

205-ECU/IMG_6052_w160_h120_cw160_ch120_thumb_c-stsa.co.uk.jpg

Go my ECU diagnostic port working. Pin 43 (Grey/white) is the ECU K line connection. Which is pin 7 on the OBD-II socket. OBD 4-5 is GNd and 16 is perm 12V.
I used VCDS-Lite with a cheap interface from Ebay, and also had a VAG-COM Fault code reader U281 also from ebay. This is a standalone reader, is a bit more portable, and gets it power from the OBD socket.
Anyway, these are the faults as displayed at the moment.

18010 P1602 Power Supply (B+) Terminal 30 Low Voltage
17925 P1517 Main Relay Circ. Electrical Malfunction
18044 P1636 Data Bus Powertrain missing message from Airbag control
17834 P1426 Tank Vent.Valve Open
17526 P1118 O2 Sensor Heater Circ. Bank1-Sensor2 Open
17841 P1433 Sec.Air Inj.Sys.Pump Relay Circ. open
17840 P1432 Sec.Air Inj.Valve Open
17908 P1500 Fuel Pump Relay Circ. Electrical Malfunction
18057 P1649 Data Bus Powertrain Missing message from ABS Control Module
The first 3 are displayed without the engine running, the remainder are displayed with the engine running.
The only one of concern is 18010m which is a sign the alternator isnt working, but my alternator charge light goes out on my dashboard, so that would indicate as simple wiring fault. i.e not connected to the ECU.
http://dtcsearch.planetvag.com/ is a good website for decoding multiple Vag DTCs


Posted by Steve | Permanent link | File under: powertrain, ecu, electrical

May 07 2011

Welding of door lock plates, Dashoboard gone for flocking, headlight into front clam shell

415-DoorFitting/IMG_6046_w160_h120_cw160_ch120_thumb_c-stsa.co.uk.jpg

Took the dashboard, instrument cluster and center console aluminium panel to Souther Flocking Services in Newbury to be fitted with a black flock coating.
Should take about 3 days to complete. If need a flocking James is good guy and will look after you.

Welded in some short brackets to hold the end of the door release cables for driver and passenger doors.
Welded some M8 bolts to the top of the rear bulkhead cross member to hold a bracket for holding the air filter. The air filter will suck air in from the behind the passenger seat.

Welded in some additional plates to raise the height of the set belt harness bar. Currently drilled with an M10 hole, but may need to be enlarged to 1/2" when the harness bar arrives. Need to get a measurement and inform marlin so the harness bar can be made.

Offered the headlights upto the front clam shell holes to start fitting these, and held them in place with duck tape for now. Still looks like I have to remove some from plastic housing from the drivers side.


Posted by Steve | Permanent link | File under: structual, lighting

May 05 2011

Windscreen & Headlights

412-Headlights/IMG_6050_w160_h120_cw160_ch120_thumb_c-stsa.co.uk.jpg

Rested the windscreen in position and adjusted the roll cage, to fit around the screen as best as possible. Locked off the M10 nuts so it wont move.

Removed windscreen and stored again.
Need to remove the side panels, and drill upper roll cage support mounts.


Bought the light bulbs for the angel eyes.
4 x H7 12V 55W (headlight and main beam)
PY21W amber indicator
W5W white side light.

Fitted bulbs to headlights, wired in to chocolate blocks for testing. Wiring for headlights is all correct. Started soldering the connections and will fit an 8 way plug so front clam can be removed.


Posted by Steve | Permanent link | File under: lighting

May 03 2011

Steering lock fixed

072-SteeringColumn/IMG_6032_w160_h120_cw160_ch120_thumb_c-stsa.co.uk.jpg

For some reason my steering lock wouldn't activate so I investigated the reason and solved it.
I removed the cylinder lock housing by drilling out the ruptured security bolts that secure it to the steering column. This exposed the locking pin, testing it with the key showed the lock worked with the key, the hole on the underside of the steering colum was covered by the tube on the inside of the column, loosening the steering column adjustment handle and pulling the wheel forward exposed the locking grooves, so the problem was easily solved by remove about 40mm of the outer tube of the lower part of the steering column.
Once removed I reassembled everything and replaced the rupture bolts with high tensile M8 button head, hex key bolts, secure with plenty of lock tight.
Once reassembled it is not possible to get to the bolts as the dashboard will be in the way.
Problem solved :)


Posted by Steve | Permanent link

May 02 2011

Heater matrix

460-HeaterMatrix/IMG_6028_w160_h120_cw160_ch120_thumb_c-stsa.co.uk.jpg

Finally fitted the heater matrix, glued with PU sealant the matrix housing onto the support bracket. Sealed the housing box, and fitted aluminium hose to connect the fan to the inlet of the matrix housing, all sealed with PU glue.
Fitted the center console side panel, with rivnuts, and fitted the center console switch panel. All works nicley and the fan performs as required.


Posted by Steve | Permanent link

Apr 28 2011

Dashboard instruments

300-Dashboard/IMG_6017_w160_h120_cw160_ch120_thumb_c-stsa.co.uk.jpg

Spent the day making some holes for dashboard switches and controls.
Hole for heater matrix control, fan switch, dashboard vents and horn button.

I has to move the dashboard vents once the holes were cut as the inlet for the drivers side vent was too close to the steering column mount. I then filled the slot with fiber filler.

While the fiber filler was out I fiber filled all back of the clam shell securing brackets, this should make them much stronger and allow a tighter lock.


Posted by Steve | Permanent link | File under: interior

Apr 27 2011

Setting the ride height

110-RearSuspension/IMG_5977_w160_h120_cw160_ch120_thumb_c-stsa.co.uk.jpg

Managed to jack up the suspension quite a bit to give 4 1/2" of ground clearance. Seems ok to me the origninal 3" is a bit low, given a speed bump has a maximum legal height of 4".

Might have to increase the rear spring rate from 300lbs to 350lbs and get a slightly longer spring by an inch. The collar ont he suspension is wound up almost the to the max. leaving no room for further adjustment.


Posted by Steve | Permanent link
< 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 >